CCNA 3: LAN Switching and Wireless

Transición CCNA Antigua a la Nueva Certificación CCNA Routing and Switching

Cisco anuncio la nueva versión CCNA llamada CCNA Routing and Switching le cambiaron el nombre también hace ya algún tiempo, las buenas noticias es que para la gente que ya tenia la CCNA antigua pueden solicitar su certificado nuevo sin costo alguno (CCNA Routing and Switching), la otra buena noticia es que ya no cobran por obtener el certificado digitalmente (PDF).

Esto lo pueden realizar desde:

  1. Cisco certification tracking system
  2. En el área Certifications, Certification Fulfillment
  3. Luego seleccionar 1 Kit (por defecto esta en 0) en Kit de certificación electrónica (versión PDF)
  4. Le damos en continuar, nos aparecerá la confirmación de información le damos continuar.
  5. Finalmente nos debería de aparecer algo como lo siguiente y 0 Costo.

Luego a esperar generalmente el proceso toma de 1-2 días y tendrán el nuevo certificado de CCNA Routing and Switching, esto como premio para la gente que ya es CCNA, cabe destacar que la gente que logre la versión actual de la certificación (640-8XX) antes del 30 de Septiembre de este año 2013 también podrán pedir la nueva versión.

¿Cuales son los cambios?

  1. Los exámenes antiguos ICND1 (640-822), ICND2 (640-816) y CCNA (640-802) estarán disponibles solo hasta el 30 de Septiembre de este año 2013.
  2. La actualización de los nuevos exámenes a grandes rasgos incluye IOS v15, Soporte de IPv6, Licenciamiento del IOS e implementación de seguridad simplificada para 802.1x
  3. Con estos nuevos cambios Cisco también anuncio que la certificación CCENT será la única certificación como pre-requisito para CCNA Security, CCNA Voice, CCNA Wireless y CCDA.

Mapeo de Track Antiguo al nuevo:

Material de estudio para la nueva certificación CCNA Routing and Switching

Como era de esperarse lo mejor para prepararse son los libros oficiales de Cisco Press estos tienen 2 series, la primera serie Foundation Learning Guide los cuales son de 0, el problema con esto es que de momento solo esta disponible el Interconnecting Cisco Network Devices, Part 1 (ICND1 Cod. 100-101) Foundation Learning Guide, 4th Edition, escrito por Anthony Sequeira por el contrario ICND2 Cod. 200-101 aún no pero al parecer tiene fecha para este año 2013.

 

 

 

Por el contrario tenemos la serie Official Certification Guide y esta si viene con todo, esta disponible por libros separados o juntos en una sola Libreria recomiendo esta ultima opción incluye los DVD con los Test de practica, etc y escritos nuevamente por Wendell Odom.

 

Cisco CCNA Routing and Switching 200-120 Official Cert Guide Library

Cisco CCENT/CCNA ICND1 100-101 Official Cert Guide

Cisco CCNA Routing and Switching ICND2 200-101 Official Cert Guide

 

Sigue leyendo

¡Regístrate para la Competencia Internacional CCNA NetRiders de Cisco Networking Academy!

El registro estará abierto del 1 de Agosto hasta el 15 de Septiembre del 2012
 
Instructores de Networking Academy: Asegúrense de que sus estudiantes se registren para la competencia de habilidades NetRiders. ¡Sus estudiantes podrán ganar un viaje a Silicon Valley! No se lo pierda—El registro termina el 15 de septiembre.

La competencia de habilidades NetRiders 2012 está abierta a todos los estudiantes de CCNA de Networking Academy en Latinoamérica y el Caribe. Ésta es una gran oportunidad para que los estudiantes construyan su curriculum, prueben sus habilidades en redes y ganen reconocimiento en el mercado laboral. Además, ¡los mejores competidores tendrán la oportunidad de ganar un viaje de estudios todo pagado a las oficinas centrales de Cisco en San José, California!

Para que los estudiantes sean elegibles para la competencia, éstos tendrán que estar actualmente inscritos en un curso de CCNA Exploration o CCNA Discovery o haber estado en uno de ellos en los últimos 10 meses. (Vea el documento Preguntas Frecuentes en nuestro sitio web para ver la lista de los cursos que son elegibles).

La competencia NetRiders está dividida en las siguientes fases:

·         Registro Abierto (1 de Agosto a 15 de Septiembre) – Contraseña de acceso: LATAM_2012_compete
·         Fase uno: Ronda clasificatoria (17 al 28 de Septiembre)
·         Fase dos: Clasificatoria Nacional (17 al 26 de Octubre)
·         Fase tres: Finales Internacionales (7 de Noviembre de la 1:00 a las 5:00 pm GMT- 3 horas)
Premios y reconocimientos para los ganadores incluyen:
·         Fase uno – Los competidores con los 5 mejores resultados de cada academia avanzarán a la siguiente fase. (Para avanzar deberá obtener un resultado mínimo de 60%). El certificado de participación estará disponible para descarga y la lista de ganadores de cada país será publicada en el sitio web de NetRiders.
·         Fase dos – Los ganadores nacionales más los participantes con los mejores resultados individuales de las 25 mejores academias por región (la lista será publicada en el sitio web) avanzarán a la fase dos. Los ganadores nacionales recibirán un Ipod touch de Apple y certificados electrónicos personalizados.
·         Fase tres – PREMIO MAYOR: Los cuatro mejores competidores en las finales internacionales (uno de cada región – consulte las reglas para detalles) recibirán un viaje de estudios todo pagado a San Jose, California.
¡Por favor, anime a sus estudiantes a participar en este emocionante evento!

IMPORTANTE: Asegúrese de darle a sus estudiantes la contraseña de acceso hoy: LATAM_2012_compete

Se requiere que los instructores supervisen a los estudiantes competidores en algunas partes de la competencia. Tanto los estudiantes como los instructores supervisores deben registrarse en www.academynetriders.com. Los estudiantes sólo podrán inscribirse en uno de los idiomas ofrecidos en la competencia, (inglés, español o portugués). Los instructores supervisores podrán inscribirse en más de un idioma, sólo en el caso de que tengan a estudiantes compitiendo en dichos idiomas.

Webinar de Cisco sobre Netspace

Cisco Netspace, nuestro Nuevo Ambiente de Aprendizaje

Cisco NetSpace

Cisco Networking Academy se complace en anunciar el Cisco NetSpace, nuestro nuevo ambiente de aprendizaje que reemplazará el Academy Connection. NetSpace es la segunda fase de Academy Evolution y corresponde a la evolución de la tecnología que todos han estado esperando!

NetSpace combina el estado de arte en aplicaciones SaaS para el aprendizaje y la colaboración, motivada en las necesidades del mercado educativo y en las tendencias y mejores prácticas en educación.

NetSpace integra Canvas de Instructure como el sistema de gestión de aprendizaje (LMS) con herramientas de aprendizaje social, colaboración, así como software para la gestión de los procesos, para usted y toda la comunidad de NetAcad. También la plataforma contará con herramientas sofisticadas de reporte y análisis como elementos fundamentales para el seguimiento.
 

La enseñanza es más simple, más productiva

Con la explosión de las redes sociales y los dispositivos móviles, vivimos en un mundo más conectado.  NetSpace provee una variedad de opciones de comunicación para mantenerlo a usted conectado con sus cursos, sus estudiantes, sus colegas y con Cisco.

Las herramientas disponibles apoyan sus propio estilo de enseñanza para poder motivar más a sus estudiantes, fomentando el aprendizaje social e informal, facilitando además laincorporación del aprendizaje a distancia para modelos de enseñanza híbridos.

La interfaz intuitiva facilitará a estudiantes e instructores poder iniciarse en NetSpace de forma natural e inmediata.

 
Una experiencia de aprendizaje para el siglo 21

Conceptos como “trabajo colaborativo”, “compartir el conocimiento” y “resolución de problemas en equipo” están asociados con las destrezas que los estudiantes hoy deben aprender.  Con las herramientas de colaboración y comunicación integradas en NetSpace, los estudiantes podrán desarrollar estas competencias durante su proceso de aprendizaje con Cisco Networking Academy, para que sean más competitivos.

 
Disponibilidad

NetSpace fue lanzado este 1 de julio de 2012 como una versión beta para una pequeña comunidad.  Pero muy próximamente estará disponible para toda la comunidad.  Por esta razón es muy importante que usted se vaya familiarizando con esta nueva plataforma.

Una vez que finalize este periodo de prueba, NetSpace será liberado y estará disponible para toda la comunidad de NetAcad.  Usted podrá actualizarse a NetSpace a lo largo de un período de tiempo de transición.  Nosotros recomendamos que todos los instructores planifiquen hacer su actualización en el transcurso de los próximos meses para que el siguiente ciclo académico puedan utilizar NetSpace para sus cursos.  Una vez que usted realiza la actualización, podrá continuar accediendo el Academy Connection para la información histórica de sus cursos.  Más detalles serán comunicados próximamente.

 

¿Está usted listo para conocer más?

Para encontrar la información actualizada sobre NetSpace y para aprender más sobre las características y beneficios de esta nueva plataforma de aprendizaje, por favor visite la sección de Academy Evolution en la comunidad Club Netacad para ver los recursos disponibles y participar en los grupos de discusión y los foros.

  •  Ingrese a las comunidades de NetAcad en: http://community.netacad.net
  •  Nevegue hacia Academy Evolution y seleccione la comunidad Club Netacad
  •  Observe el video de Amy Christen, VP de Corporate Affairs y Gerente General del Cisco Networking Academy, hablando sobre Cisco NetSpace
  • Dentro de los recursos disponibles hay videos, presentaciones, tutorials, documentos de preguntas frecuentes entre otros
  • Encontrará información reciente sobre el proceso para la actualización a NetSpace.
  • Además puede hacernos sus preguntas en el foro de discusión.

Adicionalmente estaremos realizando un webinar el día viernes 6 de julio en español donde estaremos compartiendo más información sobre Cisco NetSpace para la comunidad de habla hispana.  Este webinar será a las 15:00 GMT (9:00 Centro América, 10:00 México – Bogotá, 10:30 Venezuela,  11:00 Santiago, 12:00 Buenos Aires).   El URL para registrarse a este webinar es:
https://cisco.webex.com/ciscosales-sp/onstage/g.php?t=a&d=204820896

Esperamos contar con su participación!

Atentamente

José Pablo Esquivel
Technical Advocacy Team

Volvieron las clases Online!

Después de algunos meses sin actividad hemos vuelto con estas clases online.

¿Estás estudiando Exploration 3 ? ¿Switching? ¿Vlans? ¿No le entiendes a tu profesor?

Aqui puedes aprender y repasar los conceptos!

En esta oportunidad presentamos los siguientes temas:

1. VLANS y VTP – sábado 12 de Mayo a las 16:00 de Chile.(CLT):  REGISTRO ABIERTO

2. Introducción a OSPF – sábado 19 de Mayo a las 15:00 horas de Chile (CLT) : REGISTRO ABIERTO

En el formulario de registro puedes ver la hora de tu localidad

No te la puedes perder.

Es gratis y los cupos limitados!

Saludos

Juan Carlos Spichiger

Staff RedesCisco

Videoclase 15: Configuración de Etherchannel, VLANs, VTP y Spanning Tree

Configuración de Etherchannel, Vlans, Vtp y Spanning Tree from Juan Carlos Spichiger on Vimeo.

Seguridad en capa 2: VLAN Privadas

Las VLAN tradicionales permiten a los diseñadores de redes crear topologías más seguras y adaptables limitando el tamaño de los dominios de broadcast (difusión) y así facilitar las tareas de administración, operación y seguridad. Dentro del clásico modelo jerárquico de tres capas la aplicación de VLANs resulta vital para un buen funcionamiento y optimización del tráfico de red desde los extremos (no confundir con “bordes”) donde se ubican los clientes hacia el core principal y las demás instalaciones.

Existen, sin embargo, situaciones donde la creación de múltiples VLANs pueden ser más un problema que una real solución y es aquí donde entra a jugar un rol importante la creación de las VLAN privadas (PVLANs).

Básicamente las PVLANs permiten aislar los puertos de switch dentro de un mismo dominio de broadcast, evitando que los dispositivos conectados en estos puertos se comuniquen entre sí aunque pertenezcan a la misma VLAN y subred.

Existen 3 tipos de puertos PVLANs:

- Promiscuous: un puerto en este estado puede comunicarse con todos los demás puertos, incluso en estado Isolated y Community dentro de una PVLAN.

- Isolated (Aislado): Un puerto en este estado está completamente aislado a partir de la capa 2 dentro de la misma PVLAN, pero no de un puerto en estado promiscuo. Las PVLANs bloquean todo el tráfico hacia los puertos aislados excepto el tráfico proveniente de los puertos promiscuos. El tráfico originado en un puerto aislado se reenvía solamente HACIA un puerto promiscuo.

- Community: Los puertos en este estado se comunican entre ellos y con sus respectivos puertos promiscuos. Estas interfaces están separadas a nivel de capa 2 de todas las otras interfaces en otras comunidades o puertos aislados dentro de la PVLAN.

Típicamente una PVLAN contiene N puertos privados y un único puerto Uplink.

Veamos un ejemplo de configuración típica de VLANs en un Switch layer 3

VLAN tradicional

En este entorno tenemos naturalmente las ventajas propias de las VLAN, pero existen también algunas desventajas como por ejemplo que por cada grupo de usuarios se debe crear una subred, aunque exista solo un host. Algunos dirán que podremos aplicar VLSM para solucionar eso pero no hay que olvidarse que al aplicar VLSM se “sacrifica” toda una porción de la red para crear subredes y además el bloque más pequeño que se puede crear requiere al menos 4 direcciones IP /30. Otra desventaja es que no solo se desperdician direcciones IP si no que también VLAN-IDs ya que es necesario crear tantas VLAN como grupos de usuarios se requieran. En un entorno de producción complejo pueden llegar a agotarse fácilmente los VLAN-ID disponibles.

Las Private VLANs vienen a solucionar este problema de una manera más elegante y flexible, ya que solo necesitamos una VLAN, la misma subred para todos los hosts y aún así quedarían aislados entre ellos a nivel de capa 2.

PVLAN

 Aquí hemos creado el mismo escenario pero esta vez solo utilizando el bloque 192.168.0.0/26 para todos los hosts en la VLAN primaria 100 y dentro de ésta hemos creado VLANs privadas diferenciando los grupos anteriores. Una forma sencilla de explicar las PVLANs es una o más VLANs dentro de otra principal. Una vez que las tramas salgan de cada host y atraviesen el switch hacia las redes externas serán etiquetadas como VLAN100 y no por su ID privado ya que este es válido solamente dentro de la VLAN primaria 100.

Configuración:

Paso N°1, poner el switch en modo VTP Transparente ¿por qué?, la respuesta requiere de un poco más de análisis en el comportamiento de VTP que van más allá de este artículo pero una búsqueda en Google puede ayudar.

SW(config)# vtp mode transparent
Setting device to VTP TRANSPARENT mode.

Luego creamos las VLANs como habitualmente lo hacemos. Primero crearemos las VLAN privadas y luego las asociaremos a la VLAN primaria (solo por comodidad en el orden de los comandos)

SW(config)# vlan 101
SW(config-vlan)# private-vlan isolated
SW(config-vlan)# vlan 102
SW(config-vlan)# private-vlan isolated
SW(config-vlan)# vlan 103
SW(config-vlan)# private-vlan isolated
SW(config-vlan)# vlan 100
SW(config-vlan)# private-vlan primary
SW(config-vlan)# private-vlan association 101,102,103

Una vez creadas las asociaciones correspondientes debemos definir el rol de los puertos en cada PVLAN:

SW(config)#interface fa0/1
SW(config-if)#switchport mode private-vlan host
SW(config-if)#switchport private-vlan host-association 100 101
SW(config-if)#interface fa0/2
SW(config-if)#switchport mode private-vlan host
SW(config-if)#switchport private-vlan host-association 100 101
SW(config-if)#interface fa0/3
SW(config-if)#switchport mode private-vlan host
SW(config-if)#switchport private-vlan host-association 100 102
SW(config-if)#interface fa0/4
SW(config-if)#switchport mode private-vlan host
SW(config-if)#switchport private-vlan host-association 100 103

La configuración no es muy compleja pero las PVLANs están soportadas solamente en switches Catalyst 3560 y superiores.

Más información:

http://www.cisco.com/en/US/tech/tk389/tk814/technologies_configuration_example09186a008017acad.shtml

http://blog.ine.com/tag/private-vlan/

http://www.cisco.com/en/US/docs/switches/lan/catalyst3750/software/release/12.2_25_see/configuration/guide/swpvlan.html

También pueden encontrar información detallada en los libros de CCNP SWITCH.

Videoclase 13: Administración remota de Switches Cisco mediante CLI y Software Cisco Network Assistant

Si no sabes como administrar un switch cisco aca te mostramos como:

Administración de Switches Cisco from Juan Carlos Spichiger on Vimeo.

Además se muestra el software Cisco Network Assistant funcionando sobre una topología con equipamiento real.Te invitamos a verlo.Saludos
Juan Carlos Spichiger

Mitigando ataques de DHCP Spoofing utilizando Snooping en Switches Cisco

Snooping

Como muchos de ustedes saben, una de las formas que tienen los administradores de red, de entregar direccionamiento ip es mediante un servidor DHCP. El servidor DHCP escucha los broadcast generados por los host e inicia un ciclo de conversación hasta que finalmente entrega la dirección ip. Hasta aquí todo bien. Quizás muchas de las personas que lean este artículo  les  habrá pasado que en la red local aparece un segundo DHCP causando estragos en nuestra red LAN. Esto se conoce como el DHCP SPOOFING, en palabras simples un servidor DHCP que suplanta o interfiere con el verdadero DHCP corporativo. Si nuestra red local no cuenta con la protección adecuada es bastante dificil contener este tipo de ataques, donde tendremos constantes caídas de la red local.

En los Switches Cisco se cuenta con una solución que se llama Snooping, que es una función del equipo que sirve para repeler este tipo de ataques. Es muy simple el funcionamiento. Sólo hay que declarar el puerto al cual está conectado el DHCP corporativo(Trust) y ya está funcionando.  Veamos como se hace:

Primero se activa Snooping en el Switch

Switch(config)#ip dhcp snooping

Luego se entra a la interfaz o interfaces(que es donde va estar nuestro DHCP corporativo) y se aplica el comando que declara el puerto como trust. Por defecto cuando se activa snooping todos los puertos pasan a ser puertos untrust.

Switch(config-if)#ip dhcp snooping trust

También hay que considerar si nuestro switch tiene VLANS asociadas a estos puertos, en ese caso se aplica:

Switch(config)#ip dhcp snooping vlan 10,20 ….etc. según necesitemos.

Con esto, nuestro Switch nos ayudará a contener el ataque o en caso que alguien levante un segundo servidor DHCP en nuestra red lan. Verán que este servidor DHCP Malicioso no afectará nuestra red.

Espero que les sea de mucha utilidad.

Saludos

Juan Carlos Spichiger

Cambiando la prioridad de puerto en Spanning Tree con Packet Tracer

Quienes estén estudiando Spanning Tree (STP) en CCNA 3 o ya lo hayan hecho se darán cuenta que en el curriculum oficial de Cisco Networking Academy se explica muy bien cual es la operación de este complejo protocolo.

En una de las clases que yo estaba dictando sobre STP nos tocó configurar una topología simple donde había que cambiar la prioridad de Spanning Tree a fin de influenciar la elección del root bridge. No olviden que de forma predeterminada los switches escogen el root bridge de la topología comparando los valores de prioridad, dirección MAC y VLAN. Como todos los switches traen de forma predeterminada la prioridad en 32768, entonces el valor que rompe el empate (tie break) es la dirección MAC. El que tenga la MAC más baja se convierte en root bridge.

Luego de escoger el puente raíz, los switches deben determinar el rol de cada puerto troncal, ya sea para ponerlo como designado (ALTN), no designado o raíz. En ciertos casos se da que dos switches deben competir por asignar el rol a un puerto y ambos extremos del mismo enlace tienen los mismos valores por lo que no pueden decidir quien usa que rol. Para romper este empate, esta vez a nivel de puertos, entra a competir la prioridad de puerto + identificador de interfaz. La prioridad de puerto por defecto es 128 para todos los puertos de un switch, por lo que el valor utilizado es el identificador. Ejemplo, tanto una interfaz FastEthernet 0/1 y una interfaz FastEthernet 0/2 tienen una prioridad de 128 cada una, pero como el ID 0/1 es más bajo, esa se prefiere para configurarse en un rol designado y el otro quedaría como no designado.

Se puede configurar manualmente la prioridad de puerto con el comando de configuración de interfaz spanning-tree port-priority XXX donde XXX es un cualquier valor entre 0 y 240 con múltiplos de 16.

En esta clase decidimos cambiar la prioridad de puerto manualmente tal como lo muestra el curriculum, pero nos dimos cuenta que en Packet Tracer no funciona este comando.

STP port priority

Esta es la imagen que muestra la currícula de Cisco donde se explica el concepto de prioridad de puerto, pero en Packet Tracer no funciona:

S1(config)#interface f0/1
S1(config-if)#spanning-tree port-priority 112
                                               ^
% Invalid input detected at ‘^’ marker.

S1(config-if)#spanning-tree ?
  bpduguard       Don’t accept BPDUs on this interface
  guard              Change an interface’s spanning tree guard mode
  link-type          Specify a link type for spanning tree protocol use
  portfast           Enable an interface to move directly to forwarding on link up
  vlan                VLAN Switch Spanning Tree
S1(config-if)#

Luego de hacer las consultas respectivas al team de corrección de errores de Cisco Networking Academy, me aclararon que efectivamente esto no era un error de escritura si no que Packet Tracer al tener un IOS básico en los switches no soporta directamente el comando port-priority en la interfaz, pero que en los switches reales si funciona.

La solución es utilizar spanning-tree vlan X port-priority 112 donde X es el número de la VLAN a la cual pertenece el puerto, o bien la VLAN nativa.

S1(config-if)#spanning-tree vlan 1 port-priority 112
S1(config-if)#

 En este caso Packet Tracer sí acepta el comando.

 

 

 

 

Videoclase 9: Switches de Layer 2 y Workshop Práctico Online

Switches

 

Amigos de la comunidad RedesCisco, nuestra proxima clase online será de switches de Layer 2, orientado a la tecnología Cisco.

Revisaremos conceptos como:

- Redes Ethernet 802.3

- Dominios de Broadcast y Dominios de colisión

- Funcionamiento de los Switches de Layer 2

- ¿Que es la tabla CAM?

- Métodos de conmutación

- Configuración inicial

- ¿Como se administra un switch?

- Seguridad en los switches.

- Workshop Técnico Online de los tópicos revisados anteriormente. La idea es que ustedes prueben comandos y configuraciones básicas demostradas en la clase. (tiene requisitos)

Los requisitos son:

- Tener instalado Packet Tracert Version 5.3.1.0044

- Tener instalado el software Hamachi. Lo pueden descargar en (www.logmein.com) es gratuito. En clase online se explicará como funciona.

Luego de instalar el software hamachi (en modo sin gestión)deben unirse a la red que se llama:

Nombre: redescisco

password: redescisco2010

Nota: En hamachi deben asegurarse de configurarlo con su nombre y apellido para nosotros poder identificarlos posteriormente.

es muy fácil!

 

No se lo pueden perder. Cupos limitados.

Pueden registrarse en el widget azul del lado derecho de la página.

 

Cordialmente

Juan Carlos Spichiger

jspichiger@gmail.com

Encuesta

Encuesta VideoClase
¿Que tema te gustaría?

Síguenos

Lista de correos

Grupos de Google
Suscribirte a Redes Cisco.NET
Correo electrónico:
Consultar este grupo

Puedes ayudarnos!

Síguenos!

Subscribe via RSS

Sitios Recomendados